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NeuronMetrics User Manual 
 
 
NeuronMetrics™ (Narro et al., 2007) is a semi-automated software tool that computes a 
skeletonized representation of the neurite arbor, the cell body region of interest (ROI), 
and the neuron’s bounding convex polygon. From these features it calculates total neurite 
length, Polarity Index (PI), branch number, and the area and perimeter of the polygon. 
NeuronMetrics is implemented as Java plugins for NIH’s ImageJ image analysis software, 
which was developed by Wayne Rasband and is in the public domain.  
 
NOTE: In this PDF file, use the bookmarks to go directly to different sections of this 
manual. If you are viewing this pdf with Adobe Reader, when you follow a link, note that 
there are unlabeled “Forward” and “Back” navigation arrows at the bottom of Adobe Reader 
(the arrows with circles around them). The blue diamond bullets () indicate steps the user 
performs. 
 
To use NeuronMetrics, you must first download and install ImageJ and all necessary plugins 
as described under the Installation section. Also note the file naming rules. 
 
The NeuronMetrics Overview describes what the software does. Additional information is 
published in Narro et al., 2007. The Quick Reference Instructions provide both a handy 
reference for experienced users and an overview of the processing steps in the 
NeuronMetrics pipeline. The Detailed Instructions provide new users with step-by-step 
instructions to using NeuronMetrics. New users are advised to read the NeuronMetrics 
Overview and Quick Reference Instructions to gain an understanding of the software before 
trying to use it with the aid of the Detailed Instructions. 
 
 

Copyright Notice and Disclaimer 
 
This work of authorship identified as "NeuronMetrics v1.0" (the Work) is Copyright 2007 by the Arizona 
Board of Regents (ABOR). This Notice must remain attached to the Work. The Work and any modified 
versions of the Work explicitly permitted below must be attributed to The University of Arizona. Unless 
explicitly permitted below, it is unlawful to reproduce, modify, distribute, perform (or execute), or display 
(or generate images through use of) the Work in its original or any modified form. THIS WORK IS 
PROVIDED "AS IS," AND ABOR MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR IMPLIED. BY 
WAY OF EXAMPLE, BUT NOT LIMITATION, ABOR MAKES NO REPRESENTATION OR WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF THE WORK WILL NOT 
INFRINGE ANY THIRD PARTY PATENTS, COPYRIGHTS, TRADEMARKS OR OTHER RIGHTS. ABOR DOES NOT 
AGREE TO BEAR ANY LIABILITY FOR ANY USE OF THIS WORK. The names and trademarks of ABOR and The 
University of Arizona may not be used in advertising or publicity pertaining to the Work without written 
prior permission. Nothing in this Notice confers any title to the Work. Within the limitations specified in 
this Notice, the following rights are granted to the recipients specified below: a right to modify the Work 
and prepare derivative works based on the Work; a right to perform the Work which, in the case of 
computer software, means a right to execute the software instructions contained in the Work; and a right 
to display the Work which, in the case of computer software, includes a right to display images or screens 
generated by the Work. Within the limitations specified in this Notice, the rights specified above are 
granted to the individual in a registered not-for-profit organization who acquired the Work directly from 
The University of Arizona or its agent. Rights specified above are granted solely for the purposes of 
research and education, and do not permit incorporation of the Work, or any part of the Work, in a 
product or service offered for sale. This Notice applies to this Work only, and was prepared on February 1, 
2007, based on information submitted by the author(s) to the University of Arizona Office of Technology 
Transfer under the following identifier:d4437991acd7e5b11c3e33fdb92dcbc0 
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NeuronMetrics Overview 

 
For a published description of NeuronMetrics, including its biological context, algorithms 
used, validation, and comparison with other image-analysis approaches, see Narro et al. 
(2007). 
 
Optimal processing with NeuronMetrics requires high-contrast images of neurons as input. 
NeuronMetrics computes a skeletonized representation of the neurite arbor, the cell body 
region of interest (ROI), and the neuron’s bounding convex polygon. 
 

 
The neurite skeleton (dominant primary neurite in magenta, remainder in green) provides 
an excellent representation of neuronal morphology, cell body region of interest (dark blue) 
and the neuron territory (orange polygon). All have been thickened to 3 pixels to improve 
visualization. (Adapted from Fig. 1 of Narro et al., 2007.) 
 
These features are used to quantify the length of the arbor, branch number estimate, 
primary neurite number, and territory. All numeric data are output to a single tab-delimited 
text file that may be imported into other software for further analysis. 
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Schematic Overview 
 

 
 
The schematic overview (adapted from Fig. 2 of Narro et al., 2007) shows NeuronMetrics’ 
image processing steps. The main modules are Setup, Neuron & Cell Body, Skeletonize & 
Improve, Length Correction (optional), Dominant Neurite (optional), and Measure Skeleton. 
In Setup, a dialog box is used to indicate the location of the input images, their scale, which 
skeletonization mode to use for the input image set (see Uniform Versus Non-uniform 
Neuron Signal), and the optional steps to be performed. [continued on next page] 
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Processing begins with the Neuron & Cell Body module which runs a suite of four modules. 
If a secondary label is also imaged, this image will be displayed alongside the primary 
image. The Neuron ROI, NoiseROIs (optional), and Click Cell Body modules run sequentially 
on each displayed neuron image, allowing the user to circle the neuron of interest, circle 
noise to eliminate it (optional), and click to indicate the location of the cell body. 
Afterwards, the folder of images is automatically run through the Cell Body ROI module. 
The user runs the Skeletonize & Improve module to skeletonize the neuron (Skeletonize 
Neuron module), fill gaps in the skeleton and remove disconnected noise (Improve Skeleton 
module). These steps are fully automated unless the skeletonization mode for the neuron 
images varies. In this case, the module pauses with the image displayed and prompts the 
user to indicate which skeletonization mode to use.  
 
If the neuron contains regions of self-fasciculation, the Length Correction module may be 
run, and if the Polarity Index is to be computed, the Dominant Neurite module is used to 
isolate the dominant primary neurite. Last, the Measure Skeleton module is run to 
automatically compute all morphometric parameters. This includes running the Polygon 
module which computes the territory. 
 
To expedite processing of a batch of neuron images from a selected input folder, input files 
are automatically opened, processed through automated steps, and closed. Output files and 
folders are automatically created, named, and saved. If the module includes manual 
intervention, the tool that will be used is pre-selected, and the user proceeds to the next 
step by pressing the space bar or clicking a button. These features greatly reduce the time 
spent on file management and maneuvering about the graphical interface. 
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Notes 

 
Running Modes 
Most plugins are designed to run in both single and batch mode. To run in single mode, 
open an image before running the plugin. To run in batch mode, first use the Setup plugin 
to indicate the input folder, then run the plugin.  
 
Do Not Multi-task 
To avoid problems, do not use any other applications while running NeuronMetrics. Do not 
move the mouse around except to provide user input that NeuronMetrics needs. This means 
do not read e-mail, read electronic journal articles, or work on some document. 
NeuronMetrics seems to get confused about which window is active. 
 
Memory Limitations 
The plugin that uses the most memory is the Dominant Neurite plugin. If images are large, 
ImageJ may run out of memory if more than one preview image is open at a time. Problems 
can occur with a 5.2 MB image and 300 MB of memory allocated for ImageJ. However with 
500 MB of memory for ImageJ and a 5.9 MB image, all preview images can be open at the 
same time. Allocating memory for ImageJ is discussed under Installation. 
 
Output 
In either single or batch mode, all output folders go to the parent of the folder containing 
the input image. We recommend creating an outermost folder to contain both the input and 
output. In other words, create a folder (e.g., Experiment 1) and put your folder of input 
images in it. Then all output folders will go to folder Experiment 1. 
 
Secondary Images 
If two types of images were acquired, each type must be in a separate folder. In other 
words, the images of the primary label must be in one folder and the images of the 
secondary label must be in a different folder (e.g., named myExper_Bgal). A plugin 
automates moving the secondary images if they happen to be in the same folder as the 
primary images. 
 
.txt files 
If you re-run a plugin that generates a text file, you must manually update the .txt files. 
 
Overwriting files 
None of the plugins over-write .txt files. Plugins do over-write .tiff and .roi files (e.g., 
skeletons, cell of interest ROIs). 
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File Naming Rules 

 
To implement automatic naming of output folders and files, a naming scheme was 
developed. It imposes the following constraints: 
 
1) image files: the last character in the name MUST be a digit.  

OK: image1, 133-2-36 
NOT OK: image1hormone, 133-2-36a 
 

2) secondary image folder: If there are secondary images, they must be in a folder named 
myExper_Bgal (case sensitive). 

 
3) secondary image files: If there are secondary images, their names must be the same as 

the corresponding primary image with “-x” appended. 
OK: image1 (primary image), image1-x (secondary image) 
OK: 133-2-36 (primary image), 133-2-36-x (secondary image) 

 
The name of the image folder is pre-pended to the name of all output folders. For example, 
given a folder named treatmentA as input, the Skeletonize Neuron plugin outputs a folder 
named treatmentA_skels. 
 
A letter, letters, or descriptive phrase is appended to the image number of output files. For 
example, given image1.tif as input, the Skeletonize Neuron plugin would output image1s.tif. 
 
The names of output folders and files are described for each plugin under both the Detailed 
Instructions and Quick Reference Instructions. 
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Installation 

 
 

Software Requirements 
 
NeuronMetrics runs on PC’s with Windows XP or 2000 operating systems. NeuronMetrics 
requires ImageJ (specifically version 1.36b), FeatureJ, and Java (specifically version 
1.5.0_03), all of which are freeware. Instructions for downloading and installing all 
necessary software components are below. 
 
 

1 - Download and Install ImageJ 
 
If you do not have ImageJ 
  Download ImageJ. 
  Follow the Downloads link.  
  Under the Windows section, download the version bundled with Java 1.5. 
  Double-click on the ij…setup icon and follow the setup prompts.  
  The ImageJ folder should now be in C:\Program Files. 
  Start ImageJ. [Note: you will later substitute a specific version of ImageJ; see 2 on p. 8] 
  Check the memory allocated to ImageJ under Edit > Options > Memory…   It should be 

set to 2/3 of the RAM or 640 MB, whichever is lower. 
  Close ImageJ. 
  Proceed to Download and Install NeuronMetrics. 
 
If you have a version of ImageJ installed 
  Check the memory allocated to ImageJ under Edit > Options > Memory…   It should be 

set to not more than 2/3 of your RAM. A setting of 640 MB is adequate if it does not 
exceed that constraint. 

  The optimal version of Java is 1.5.0_03 (see Sun Microsystems).  
  Proceed to Download and Install NeuronMetrics. 
 
An alternative approach to updating Java is to completely reinstall ImageJ bundled with 
Java, but first you must save any plugins or macros you previously installed. To keep those 
plugins or macros,  
  First move the old ImageJ folder out of C:\Program Files and put it somewhere (say, on 

the desktop). 
  Follow the instructions to download ImageJ. 
  Reinstall the plugins or macros you previously had by copying them from the old ImageJ 

folder on the desktop into the appropriate folder (plugins or macros) in the new ImageJ 
folder in C:\Program Files. 
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2 - Download and Install NeuronMetrics 

 
  Download NeuronMetricsFiles.zip from the iBridgeSM Network.  (From the Home page, 

search “NeuronMetrics”.) 
  Double-click on the NeuronMetricsFiles.zip icon and unzip it. 
  In the NeuronMetricsFiles folder there are 3 folders, 1 .txt file, and 1 .jar file. 
  Move the 3 folders (imageAnalysis, NM Tools, NeuronMetrics) into the ImageJ\plugins 

folder. 
  Move the ExpandOrShrink.txt file into the ImageJ\macros folder. Yes, overwrite the 

existing copy. The version included with NeuronMetrics has been modified to get the 
input parameters from plugins instead of popping up a dialog box.  

  Delete the existing ij.jar file from the ImageJ folder.  Move the ij1.36b.jar file, which is 
version 1.36b of ImageJ, into the ImageJ folder, and rename it ij.jar. Yes, this will 
overwrite the existing copy. 

  Start ImageJ. 
  The version of ImageJ must be 1.36b (Check by going to Help > About ImageJ... ). 

NeuronMetrics does not run with some later versions of ImageJ.  NeuronMetrics was 
tested on Java 1.5.0_03.  Some later versions of Java are not compatible with the 
Dominant Neurite module of NeuronMetrics. 

  On the toolbar under Plugins you should see NM Tools and NeuronMetrics. 
  NeuronMetrics will not yet run correctly. You need to download the “Other Required 

Plugins” (see below). 
  Close ImageJ. 
 
 
 

3 - Other Required Plugins 
 
FeatureJ: NeuronMetrics uses Erik Meijering’s FeatureJ plugin for Laplacian edge detection.  
  Download both FeatureJ_.jar and imagescience.jar   
  Put both FeatureJ_.jar and imagescience.jar in the ImageJ\plugins folder. 
  FeatureJ will appear on the toolbar under Plugins the next time you start ImageJ. 
 
Batch Converter: If you need to convert image files to 8-bit, this plugin (by Wayne 
Rasband) is required. Otherwise, it is not.  
  Download Batch_Converter.class  
  Put it in the ImageJ\plugins folder.  
  Batch Converter will appear on the toolbar under Plugins the next time you start 

ImageJ. 
 
 

Useful Optional Plugin 
 
Window Closer: Closes all windows that have opened while using ImageJ. 
  Download Window_Closer.class  
  Put it in the ImageJ\plugins folder.  
  Window Closer will appear on the toolbar under Plugins the next time you start ImageJ. 
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Quick Reference Instructions 
 

NeuronMetrics Processing Steps 
 
In ImageJ, the plugins are under Plugins > NeuronMetrics, or Plugins > NM Tools. 
Output goes to the parent folder of the folder of neuron images. To avoid problems, do not 
multi-task. 
 
 

Stitch Images 
 
(if necessary) 
• We use PanaVue software. 
• If necessary, convert to 8-bit images (use ImageJ  Plugins > Batch Converter) prior to 

stitching.  
• Both the primary and any secondary images (e.g., anti-HRP and anti-βgal, respectively) 

need to be stitched. 
 
 

Move Secondary-Label Images 
 
(if necessary) 
Move the images of the secondary label out of the folder with the primary labeled neurons.  
  Create a destination folder named myExper_Bgal. 
  Use NM Tools > File Mover. 
 
 

1 - Save Scale plugin 
 
(if necessary to measure, set, and save the scale) 
  In ImageJ, open an image containing a micrometer or scale bar. 
  Use the ‘line selection’ tool to draw a line. 
  Analyze > SetScale... 
  Leave the image open. 
  Run the 1 Save Scale plugin. 
  Close the image. 
Note: This scale is used only by NeuronMetrics plugins, not by other ImageJ functions. 
detailed instructions 
 
 

2 - Setup plugin 
 
View or change the settings. 
 
Run: 
  Set the input Neuron Folder. 
  Check the optional features you will compute. 
  We recommend saving the first 3 overlays: 

• All Computed Features 
• Cell Body ROI on Neuron 
• Improved Skeleton on Neuron 

  Click OK 
detailed instructions 
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3 - Neuron and Cell Body plugin 
 
Runs 4 plugins: Neuron ROI, Noise ROIs (optional), Click Cell Body, and Cell Body ROI. 
 
Input: (batch) neuron image folder. 
 
Also uses: corresponding secondary-labeled image (if any). 
 
Run: 
  Draw ROI around cell of interest  
  Draw ROIs around noise enclosed by the neuron (optional). 
  Click on the cell body. 
  After finishing the steps above for all images in the folder, the cell body ROI 

automatically is created for all images in the folder. 
  Check the cell body ROI overlays. 
 
Output: 
• folder myExper_cellROIs containing files image#roi.roi 
• folder myExper_noiseROIs containing files image#nz.roi (optional) 
• folder myExper_cellBodyPoints containing file myExper_ cellBodyPoints.txt 
• folder myExper_cellBodyROIs containing files image#cb.roi 
• folder myExper_cellBodyROI_overlay containing files image#cbn.tif (recommended) 
 
Troubleshooting 
• For cell body ROIs that are not satisfactory or skipped images (failures in the Cell Body 

ROI plugin), run the Cell Body Roi Manually plugin under NM Tools to manually outline the 
cell body. 

• For other failures, run the appropriate plugin individually (Neuron ROI, Noise ROIs, Click 
Cell Body, Cell Body ROI). 

• Do NOT run images that need to be stitched, but have not been. Their names violate the 
naming rules which will cause failure in later plugins. 

 
 

4 - Skeletonize and Improve plugin 
 
• Runs 2 plugins: Skeletonize Neuron, and Improve Skeleton. 
• If you have changed your mind about the uniformity of the neuron signal, use the Setup 

plugin to change the ‘Neuron Signal’ setting now. 
• Creates skeleton, then fills gaps, eliminates non-connected noise. 
 
Input: (batch) neuron image folder 
 
Also uses: corresponding Cell of Interest ROIs, Cell Body ROIs, Noise ROIs (if any). 
 
Run: 
  Fully automatic unless Neuron Signal is set to “set individually” in Setup, in which case, 

the plugin pauses on each image to let the user indicate whether the signal is uniform or 
non-uniform. 

  Check improved skeleton overlays. 
 
Output:  
• folder myExper_skels containing files image#s.tif 
• folder myExper_improvedSkels containing files image#_Improved_Skeleton.tif   
• folder myExper_improvedSkels_overlays containing files 

image#_Improved_Skeleton_Overlay.tif (recommended) 
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Troubleshooting: 
Large segment of neurite is missing from the improved skeleton due to failure to fill a gap 
in the preliminary skeleton. Fill the gap manually in the initial skeleton using ImageJ’s 
‘Straight Line Selection’ tool: 

• Open the initial skeleton & zoom in on the gap until you can see individual pixels.  
• If necessary, set the foreground color to white (Edit > Options > Colors, or double-

click the eye dropper tool). 
• Using the ‘Straight Line Selection’ tool draw a straight line between the 2 pixels at the 

ends of the gaps.  
• Draw the line (Edit > Draw). 
• It should be 1 pixel wide. Only the Straight Line tool draws 1 pixel wide, so do not use 

any other tool. 
• Save the changes to the image.  
• Re-run the edited initial skeleton through Improve Skeleton. 

 
 

5 - Length Correction plugin (optional) 
 
Use the ‘Help’ button in the plugin, or see the detailed instructions. 
 
 

6 - Dominant Neurite plugin (optional) 
 
Use the ‘Help’ button in the plugin, or see the detailed instructions. 
 
 

7 - Measure Skeleton plugin 
 
• Runs 2 plugins: Measure Skeleton, and Polygon (optional). 
• computes: total length, polarity index (optional), # primary processes, total branch 

count, and polygon data (optional) 
• finalizes skeleton: erases primary neurites that are too short (see Setup > Advanced... > 

Primary Neurites > Length Threshold) and removing the skeleton inside the cell body 
ROI. 

 
Input: (batch) improved skeleton folder 
 
Also uses: cell body points (.txt), cell ROI, cell body ROI, cell body skeleton, neuron (if 

saving overlay). 
 
Run: 
  Fully automatic. 
  Check overlay of all features computed. 
 
Output:  
• folder myExper_finalSkels containing files image#fs.tif,  
• folder myExper_skelDat containing myExper_skelData.txt and (if polygon was run)   

myExper_allData.txt 
• folder myExper_ overlaysAll containing files image#_overlayAll.tif (recommended) 
If polygon was run,  
• folder myExper_polys containing files < imageID >p.tif  
• folder myExper_polyDat containing file myExper_polyData.txt 
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Detailed Instructions 

 
Save Scale plugin 

 
Purpose 
(if necessary) 
Determines the number of pixels per unit distance in an image. If you already know the 
scale of the images in pixels/myUnits, just enter it in the Setup dialog box. The scale is 
used by NeuronMetrics plugins to convert the length and area data to meaningful units 
before output. The scale is saved and will appear under ‘Scale’ in the Setup dialog box. 
Note: This scale is used only by NeuronMetrics plugins, not by other ImageJ functions. 
 
Input 
An image containing a scale bar or micrometer. 
 
Output 
Sets and saves the scale used by NeuronMetrics plugins. View it in the Setup dialog box.  
 
How To Use 
 
  In ImageJ, open an image containing a micrometer or scale bar. 
  Select the Straight line selections tool in the ImageJ toolbar. 

 
 
  Manually draw a straight line selection (magenta) on the micrometer or scale bar in the 

image. 
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  Set the scale under Analyze > SetScale... 

 
 
Distance in Pixels: automatically filled based on the length of the straight line selection. 
 
Known Distance: enter the appropriate value. 
 
Pixel Aspect Ratio: use the default value of 1.0. 
 
Unit of Length: enter the appropriate unit. 
 
Scale: automatically reflects the values entered in the editable boxes above. 
 
Global: do not check. 
 
Click OK. 
 
  Leave the micrometer or scale bar image open. 
  Run the 1 Save Scale plugin. 

The scale should appear in the Setup dialog box (see next section) under Scale. 
  Close the image. 
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Setup Plugin 
 
Purpose 
Sets running parameters for NeuronMetrics. 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Setup. 
 

• Displays the Setup dialog box. 
 
Setup dialog box 

 
 
Neuron Folder should be set to the location of the folder containing the images to be 
processed. Use the Browse button to select a folder. 
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Destination Folder is the location of the folder where all output goes. It automatically sets 
to the parent folder of the Neuron Folder and is not editable. 
 
Scale is used for the conversion from pixels to meaningful units. This scale is used only by 
NeuronMetrics plugins, not by other ImageJ functions. 
 
Units in pixels/ are the aforementioned meaningful units. 
 
Neuron Signal sets the skeletonization mode. The best setting depends on how uniform 
the signal is within a labeled neuron. 
 

• Uniform is used for neurons with high, relatively uniform signal throughout.  
 

• Non-uniform is used for neurons in which the signal varies.  
 

• Set individually is used when some neurons in a folder have uniform signal and 
others have non-uniform signal. When running the Skeletonization plugin, a dialog box 
appears asking the user whether the displayed image should be processed in uniform 
or non-uniform mode. 

 
Noise ROIs causes this plugin to be run when the multi-step 3 Cell Body & Neuron plugin 
is run. 
 
Length Correction indicates that the user will manually run the Length Correction plugin. 
The data it generates will be used by the Polarity Index plugin (if run) and Measure 
Skeleton plugin. 
 
Polarity Index indicates the user will manually run the Polarity Index plugin. The data it 
generates will be used by the Measure Skeleton plugin. 
 
Territory causes the Polygon plugin to be run when the Measure Skeleton plugin is run. 
 
Checking any of the Save Optional Output Images boxes causes the appropriate plugin 
to run and automatically save the output image. The most useful images for monitoring the 
quality of image processing are the first three which are checked by default. 
 
Overlay of All Computed Features displays the skeleton, cell body ROI, and, if 
computed, also displays the dominant neuron and polygon. Each feature is a different color. 
 
Cell Body ROI on Neuron Overlay displays the cell body ROI on the neuron and is useful 
for catching and correcting problems in computed cell body ROI prior to continuing 
processing. 
 
Improved Skeleton on Neuron Overlay displays the improved skeleton (after gap filling 
and removal of disconnected noise) on the neuron. Useful for catching and correcting 
problems prior to further processing. 
  
Polygon, Skeleton, Cell Body Overlay displays the final skeleton (gaps filled, 
disconnected noise and cell body skeleton removed), cell body ROI, and, if computed, the 
polygon on the neuron. 
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Colored Faces Images displays the faces found as part of the branch correction. Used for 
software testing or for creating colorful Miro-esque representations of otherwise annoying, 
complex neurons. 
 
OK closes the dialog box and sets/resets the parameters. 
 
Cancel closes the dialog box without resetting the parameters. 
 
Set to Defaults resets the parameters under Run Optional Features and Save Optional 
Output Images to the NeuronMetrics default settings. The only Required parameter that is 
reset is Neuron Signal. If for some reason you want to run with no scale, manually set Scale 
to 1 and Units to “pixels” or leave it blank. 
 
Advanced… button displays the Advanced Settings dialog box (see next page). 
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Advanced settings Dialog box. 

 
 
For additional information on the parameters in Advanced Settings, see Narro et al. (2007), 
in particular online Supplement 1. 
 
Cell Body ROI 

Rolling Ball Radius is used to establish the cell body ROI. Imagine a small ball or circle 
rolling around in the cell body (soma) of the neuron image. Decreasing the radius of the 
ball allows it to roll closer to the perimeter of the soma and farther out into the primary 
neurites. 
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Skeletonization parameters are difficult to adjust effectively unless you have background 
in image processing. If necessary, adjust them until you find settings that improve 
skeletonization for your images.  

Smallest Object removes noise from the preliminary skeleton by eliminating all 
connected skeletonized objects this size or smaller. Setting this value too high may 
result in loss of short, disconnected tips of neurites. 

 
Gap Filling parameters are used in the Improve Skeleton plugin to fill gaps between 
endpoints on segments of the preliminary skeleton. 

Gap Distance is the maximum distance that the algorithm will attempt to fill. 
Extend Distance affects how closely the two skeleton fragments must be aligned for 
the gap between them to be filled. A higher value increases the alignment stringency.  
Maximum Deviation affects how closely the two skeleton fragments must be aligned 
for the gap between them to be filled. A lower value increases the alignment stringency.  

 
Branch Count parameters regarding faces affect the branch count correction. The noise 
parameter sets a length threshold for what is counted as a branch. It is imperative to read 
the paper and understand these parameters before attempting to adjust them. 

Small Face, Maximum Size is used to limit over-correction of the branch count in 
regions of self-fasciculation. Use ImageJ’s wand tool to measure the area of faces in 
self-fasciculating regions of the improved skeleton, then adjust this parameter 
accordingly. 
Medium Face, Maximum Size is used to limit over-correction of the branch count in 
regions of self-fasciculation. Use ImageJ’s wand tool to measure the area of faces in 
self-fasciculating regions of the improved skeleton, then adjust this parameter 
accordingly. 
Elongated Face is used to limit over-correction of the branch count in regions of self-
fasciculation. Use ImageJ’s wand tool prior to measuring the Feret’s Diameter of faces in 
self-fasciculating regions of the improved skeleton, then adjust this parameter 
accordingly. 
Short Noise, Maximum Size sets the upper limit on what is considered noise rather 
than a true neurite (what is too short to be a neurite). Increasing the value will reduce 
the branch count. 

 
Primary Neurites parameters are used to reduce the time required to find primary 
neurites and to set a length threshold for them. 

Length Threshold is used to exclude skeletonized neurites emanating from the cell 
body that are deemed to be too short to be true primary neurites. Increasing the value 
will reduce the primary neurite count. 
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Neuron ROI Plugin 

 
Purpose 
Indicates the neuron of interest and separates it from any adjacent neurites or noise. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: secondary label image, if any. 
 
Output 
neuron ROI 
folder myExper_neuronROIs containing files image#roi.roi 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Neuron ROI. 
 

• The plugin automatically inverts the neuron image and opens the secondary image if 
there is one. 

 
• Use ImageJ’s Freehand Selections tool, which is automatically activated, to ‘circle’ the 

neuron of interest. 
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Example of the neuron of interest circled in magenta. 

 
  Press the spacebar. 
 

• The ROI is automatically saved. 
 

• In batch mode, the plugin will proceed to the next image.  
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Noise ROIs Plugin 

 
Purpose 
Indicates noise that contacts the neuron and needs to be removed to prevent it from 
appearing as part of the skeletonized neuron. This tool is particularly useful for removing 
noise that is enclosed by neurites and therefore cannot be excluded by ‘circling’ the neuron 
when defining the Neuron ROI. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: secondary label image, if any. 
 
Output 
noise ROIs 
folder myExper_noiseROIs containing files image#nz.roi 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Noise ROIs. 
 

• The plugin automatically displays the neuron image and opens the secondary image if 
there is one. 

 
• The Noise ROI Manager window appears. 

 

 
 

Add: After ‘circling’ some noise, which creates a ROI, click Add to place an ID number 
for the ROI on the list.  
 
Delete: Select an item on the list. Note that the corresponding ROI is displayed on the 
neuron image. Click Delete to remove the ROI from the list. 
 
Quit: Quits the tool and closes all associated windows. 
 
Help: Displays instructions on how to use the tool. 
 



NeuronMetrics v1.0 User Manual (March 20, 2007)  p. 22 

 

Finished Image: After drawing 0 or more noise ROIs, click Finished Image to save any 
ROIs and, in batch mode, proceed to the next image. 

 
  Use ImageJ’s Freehand Selections tool, which is automatically activated, to ‘circle’ 

some noise. 
 

 
 

 
One ROI (magenta) circling noise. 

 
  Click the Finished Image button 
 

• Automatically saves the ROI(s) 
 

• In batch mode, proceeds to the next image.  
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Click Cell Body Plugin 

 
Purpose 
Indicates the location of the neuron’s cell body (soma). The location is used to 
automatically create the cell body ROI and in the Measure Skeleton plugin. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: secondary label image, if any. 
 
Output 
a point on the cell body 
folder myExper_cellBodyPoints containing file myExper_cellBodyPoints.txt 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Click Cell Body. 

 
• The plugin automatically displays the neuron image and opens the secondary image if 

there is one. 
 
  Click on the cell body (soma) of the neuron using ImageJ’s Point Selections tool, 

which is automatically selected. 
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A small point selection (magenta) marks the cell body. 

 
  Press the spacebar. 
 

• Adds the point to the Results table. 
 

• In batch mode, proceeds to the next image. 
 

• Automatically saves the data in the Results table at the end of the batch or single 
image. 
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Cell Body ROI Plugin 

 
Purpose 
Automatically creates the cell body ROI which is used to locate the base of primary neurites 
so they may be counted. The ROI is also used to clear the cell body skeleton from the final 
skeleton so it is not included in the total length measurement. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: cell body points, neuron ROI, noise ROIs (if any). 
 
Output 
cell body ROI 
• folder myExper_cellBodyROIs containing files image#cb.roi 
• folder myExper_cellBodyROI_overlay containing files image#cbn.tif (recommended) 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Cell Body ROI. 
 

• The plugin is fully automatic. 
 
• Various stages of image processing will be displayed briefly including: 

 

 
Edge detection and rolling ball background subtraction to enhance the cell body region. 
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The image with background cleared outside the neuron ROI, edge detection, rolling-ball 
processing, and the cell body ROI (magenta) created by ImageJ’s Wand tool. 

 
• Automatically saves the cell body ROI. 

 
  After the batch or single neuron processing is complete, view the overlay(s) of the cell 

body ROI on the neuron to check for problems. 

 
Cell body ROI overlaid on neuron. 
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Troubleshooting 
 
• If a cell body ROI is not satisfactory, or an image is skipped (a message will appear in the 

Log window), or the Cell Body ROI plugin fails on an image in some other way, run the 
Cell Body Roi Manually plugin under Plugins > NM Tools to manually draw the cell body 
ROI. 

 
• If you re-ran the Click Cell Body plugin, did you remember to manually update the .txt 

file containing the cell body point data? 
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Cell Body Roi Manually Plugin 

(Optional) 
 
Purpose 
Facilitates manually creating the cell body ROI which is used to locate the base of primary 
neurites so they may be counted. The ROI is also used to clear the cell body skeleton from 
the final skeleton so it is not included in the total length measurement. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: secondary image (if any). 
 
Output 
cell body ROI 
• folder myExper_cellBodyROIs containing files image#cb.roi 
• folder myExper_cellBodyROI_overlay containing files image#cbn.tif (recommended) 
 
How To Use 
 
  Run by going to Plugins > NM Tools > Cell Body Roi Manually. 
 

• The plugin automatically opens the neuron image and opens the secondary image if 
there is one. 

 
  Draw a ROI slightly within the cell body (see example below) using ImageJ’s Freehand 

Selections tool, which is automatically selected. 
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Manually drawn cell body ROI. 

 
  Press the spacebar. 
 

• Automatically saves the cell body ROI. 
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Skeletonize Neuron Plugin 

 
Purpose 
Creates a preliminary skeleton representing the neuron. This preliminary skeleton image is 
further processed by the Improve Skeleton plugin. 
 
Input 
batch mode: neuron image folder via the Setup dialog box. 
single mode: Open a neuron image. 
also uses: neuron ROI, noise ROIs (if any). 
 
Output 
preliminary skeleton 
• folder myExper_skels containing files image#s.tif 
 
How To Use 
 
  Set the Neuron Signal using the Setup dialog box if you have not already done so. 
 
  Run by going to Plugins > NeuronMetrics > Skeletonize Neuron. 
 

• If all images in the folder are being processed using the same skeletonization mode 
(all neurons have either uniform signal or all have non-uniform signal), the plugin 
requires no user input. It just runs.  

• If some images in the folder need to be processed in uniform mode and some in non-
uniform mode, the Neuron Signal should be set to “set individually” in the Setup dialog 
box. In this mode, a dialog Signal dialog box will appear during the processing of each 
image to let the user indicate the skeletonization mode to use. 

 

 
 

• Various stages of image processing will be displayed briefly. 
• The skeletonized image is automatically save. 
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Improve Skeleton 

 
Purpose 
Improves the preliminary skeleton by filling gaps and removing disconnected noise. This 
skeleton image is further processed by the Measure Skeleton plugin. 
 
Input 
batch mode: The preliminary skeleton image folder is automatically found based on the 

Neuron Folder setting in the Setup dialog box. 
single mode: Open a preliminary skeleton image. 
also uses: corresponding Cell Body ROIs, neuron (if saving overlay). 
 
Output 
improved skeleton 
folder myExper_improvedSkels containing files image#is.tif 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Improve Skeleton. 
 

• The plugin is fully automatic. 
• For several seconds nothing appears to be happening, but processing is occurring.  
• Various stages of image processing will be displayed briefly. 
• The improved skeletonized image is automatically save. 

 
  Check the output from the overlay of the improved skeleton on the neuron 

(recommended). 
 
Troubleshooting 
 
If the skeleton is missing a significant portion of a neurite due to failure to fill one or more 
gaps, you may manually fill the gaps: 
 
  Set the foreground color in ImageJ to white so the new pixels drawn to fill the gap 

will be white. 
 

Edit > Options > Colors... 
 

 
 
  Open the corresponding preliminary skeleton image in ImageJ. 
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  Zoom in, using the magnifying glass tool, until the pixels are large enough for you to 

accurately draw a line from one pixel in the skeleton to another. 
 

 
 

 
Zoomed in on the gap in the skeleton. 

 
  Manually draw a straight line selection between two pixels to bridge the gap using the 

Straight line selections tool.  
 

  
 

  
Straight line selection in magenta. 

 
  Draw the selection to fill the gap with pixels. 
 

Edit > Draw 
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After drawing in white, the gap is filled. 
 
Note: “Drawing” a straight line selection results in a 1-pixel-wide skeleton, as desired. 
Using other selection tools may not. If you use a different selection tool, you may have 
to re-skeletonize the image. 

 
  Save the edited preliminary skeleton image, File > Save As > Tiff…  
 
  Yes, replace the existing image. 
 
  Run the edited preliminary skeleton image through the Improve Skeleton plugin in 

single mode. 
 

• Open the image. 
 

• Plugins > Neuron Metrics > Improve Skeleton 
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Length Correction Plugin 

(Optional) 
 

Purpose 
Corrects the length in a region of self-fasciculation by drawing a free-form curve to indicate 
the length that needs to be added. The curve may be weighted. The length correction is 
used by the Dominant Neurite and Measure Skeleton Plugins. 
 
Input 
batch mode: The improved skeleton image folder is automatically found based on the 

Neuron Folder setting in the Setup dialog box. 
single mode: Open an improved skeleton image. 
also uses: neuron images 
 
Output 
Length correction data and images of the free-form lines that were drawn. 
• folder myExper_lenCorrData containing myExper _lenCorrData.txt with the numeric 

length correction data. 
• folder myExper_lenCorr containing image#lenCorr.tif (for each input image, one output 

image showing a skeletonized representation of the freeline objects the user drew). 
 
How To Use 
 
  Run by going to Plugins > NeuronMetrics > Length Correction. 
 

The plugin displays the neuron image that corresponds to the input improved skeleton 
image and the Length Correction Manager window. 

 

 
 

Add: After indicating a section of the neuron that needs length correction, which creates 
a selection object, click Add to place an ID number for the selection on the list.  
 
Toggle Skeleton: alternately displays the neuron with or without the improved 
skeleton superimposed. 
 
Delete: Select an item on the list. Note that the corresponding selection object is 
displayed on the neuron image. Click Delete to remove the item from the list. 
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Quit: Saves the data in the Length Correction Data window. Quits the tool and closes all 
associated windows. The selection images from images that were completely processed 
(the Finished Image button was clicked) before quitting have been saved already. 
 
Help: Displays instructions on how to use the tool. 
 
Finished Image: After drawing 0 or more selections, click Finished Image to save any 
selections, and to compute and write the length correction data to the data table. In 
batch mode, proceeds to the next image. 

 
  Toggle the skeleton to see how the neuron was skeletonized. 
 
  Draw a freehand line selection, the tool is automatically activated, to indicate the 

section of neurite for which length should be increased. 
 

 
 

 
Freehand line selection (magenta) 
 

  Click the Add button and a dialog box for weighting the line appears. Enter the weight. 
Fractional values may be used.  
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  When OK is clicked, the data appear in the list on the Length Correction Manager 

window. 
 

 
 

Multiple selections may be made on a single neuron or a single, long selection, 
appropriately weighted, may be made. 

 
  To delete an item, select it in the list and click the Delete button. 

 
 
  Click the Finished Image button when all corrections for the image have been made.  
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• The data are written to the Length Correction Data Window.  

 

 
 
 

• In batch mode, proceeds to the next image. 
 

• Data in this window are automatically saved as a .txt file at the end of a batch or 
single image. 

 
See  Narro et al. (2007) for additional information on Length Correction. 
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Dominant Neurite Plugin 

(Optional) 
 
Purpose 
Identifies and isolates the dominant primary neurite in the improved skeleton image so its 
length may be computed. The length is used to calculate the Polarity Index when the 
Measure Skeleton plugin is run. If the skeletonized dominant neurite does not contact other 
neurites, it just needs to be identified. If it contacts other neurites, the skeleton needs to be 
disconnected in one or more locations to isolate the dominant neurite. If it is not obvious 
which neurite is dominant, multiple neurites may be identified and isolated. The plugin will 
determine which is longest. 
 
Input 
batch mode: The improved skeleton image folder is automatically found based on the 

Neuron Folder setting in the Setup dialog box. 
single mode: Open an improved skeleton image. 
also uses: neuron images, cell body ROI. 
 
Output 
Dominant neurite length data and images of the dominant neurite and edited skeleton. 
• folder myExper_editedSkels containing edited skeleton images (image#es.tif) and a color 

version (image#ecs.tif). 
• folder myExper_domProcSkels containing dominant neurite skeleton images 

(image#ds.tif) and a colored dominant neurite image (image#drs.tif). 
• folder myExper_domProcData containing myExper_domLengths.txt. 
 
 
How To Use 
 
The Basic Steps are: 
1) 'Indicate' a neurite that is, or may be, the dominant one.  
2) Make breaks in the skeleton if that process contacts other processes.  
3) Preview your work to verify that the process is isolated. 
4) Repeat for as many process as necessary. 
5) Click 'Finished Image' when you are finished with the image. 
 
Details are provided below. The breaks in a process are not finalized until you either 
indicate another process or click the 'Finished Image' button. After 'Finished Image' is 
clicked, the length of the dominant neurite is computed and written to a data window, and 
skeleton images are saved. The length data are saved to a .txt file at the end of a batch (or 
image if in single mode). 
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Making Breaks 
With the cross-hair tool (point selections) selected,  
 

 
 
click NEAR the skeleton where you want to break it. The tool will find the NEAREST skeleton 
pixel and make the break there. The clicks are marked on the image and their x,y 
coordinates are added to the list in the Skeleton Breaker window. There are 3 types of 
breaks: 
 
Simple (click): Clicking near the skeleton results in a 'simple' break of 3 pixels centered 
on the skeleton pixel closest to the click point. A simple break is appropriate when two 
branch tips touch each other. 
 
Trimmed (t + click): Clicking while holding down the ' t ' key results in a 'trimmed' break 
in which skeleton pixels are removed from the click site to the nearest branch point in a 
manner that ensures no small branch stub remains. A trimmed break is appropriate when a 
tip touches somewhere along another process. 
 
Crossover (c + click): Like a trim, but used when there is a crossover. The difference is 
that the pixels are NOT permanently erased thereby allowing the user to edit the other 
process involved in the crossover if necessary. 
 
  Run by going to Plugins > NeuronMetrics > Dominant Neurite. 
 

The plugin displays the Skeleton Breaker window and the neuron image that 
corresponds to the input improved skeleton image. 
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Indicate Neurite: Each time you want to indicate that a primary neurite is or may be 
the longest, press the 'Indicate Neurite' button. Click on the desired primary neurite. Its 
skeleton will appear. If the neurite of interest contacts other neurites, the skeleton 
extends into those neurites and you need to click to indicate break points (see Making 
Breaks above). When you have isolated the process, either click 'Indicate Neurite' again 
if there are additional candidates for dominant neurite, or click the 'Finished Image' 
button. 
 
Undo Indicate Neurite: Used in the event of a mistake. 
 
Toggle Skeleton: Causes skeleton to disappear/reappear to provide an unobstructed 
view of the neuron. The skeleton must be visible when clicking to indicate break points. 
 
Preview: Displays the skeleton for the current process taking the breaks into account. 
Useful for determining if the process is isolated.  
Preview Neurites: Displays the skeleton for all processes worked on thus far, taking 
breaks into account. Each process is a different color. 
Preview Skeleton: Similar to 'Preview Neurites' but also displays the unprocessed parts 
of the skeleton. 
 
Delete Point: Used in the event of a mistake. Removes a break point from the break 
list. In the list, select (highlight) the point(s) to be removed, then click 'Delete Point'. In 
the image, deleted points are re-colored gray. If necessary, determine the x,y 
coordinates of the point to be deleted by mousing over it in the image. Use the x,y 
coordinates to locate the point in the list. 
 
Quit: Quits a batch. Data for the current image are NOT saved. Other images and 
length data are saved. 
 
Help: Displays this set of instructions. 
 
Finished Image: Finalizes the breaks in the last neurite edited, computes the length of 
the longest neurite. The length of the longest neurite is written to the data window and 
skeleton images are saved. 

 
 
 

 
The neuron image. 
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  Press the Indicate Neurite button. 
 

 
After pressing Indicate Neurite and clicking on dominant primary neurite (small magenta 
square), the skeleton appears. 

 
  Toggle the skeleton, if necessary, to see an unobstructed view of the neuron. 
 
  Click near a location where the skeleton needs to be broken. 
 

 
A cyan square marks the location of the click. 
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 The break point’s x,y coordinates are added to the list. 
 
  Press the Preview button to see if the neurite is now isolated. 
 

 
It is clear this dominant neurite has been isolated. 

 
  If the neurite is not yet isolated, close the preview window and continue making 

breaks and checking the preview image until the neurite is isolated. 
 
  Press the Finished Image button. 
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• The length of the dominant neurite is written to the data window. 

 

 
 

• Images of the dominant neurite and edited skeleton are saved. 
 

• In batch mode, proceeds to the next image. 
 

• The data in the Dominant Neurite Data window are automatically saved at the end of a 
batch or single image. 

 
Troubleshooting 
 
• If the plugin dies in the middle of a batch, you must MANUALLY SAVE the length data to a 

.txt file using 'File > Save As' in the data window. 
 
• Pay attention to which window is active, the image window or the 'Skeleton Breaker' 

window. The spacebar repeats the action of the last button clicked as long as the 
Skeleton Breaker window is selected (instead of the image window). This is a built-in 
feature that could not be disabled, not a bug. 

 
• If images are large, ImageJ may run out of memory if more than one preview image is 

open at a time. (Problems can occur with a 5.2-MB image and 300 MB of memory 
allocated for ImageJ. However with 500 MB of memory for ImageJ and a 5.9-MB image, 
all preview images can be open at the same time.) Allocating memory for ImageJ is 
discussed under Installation. 
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Measure Skeleton Plugin 

 
Purpose 
Finalizes the skeleton and uses it to compute the quantitative data. If computing the 
territory is checked in the Setup dialog box, the Polygon plugin is also run. The skeleton is 
finalized by erasing primary neurites that are too short (see Setup > Advanced... > Primary 
Neurites > Length Threshold) and removing the skeleton inside the cell body ROI. The data 
computed are total length, polarity index (optional), # primary processes, total branch 
count, and polygon data (optional). 
 
Input 
batch mode: The improved skeleton image folder is automatically found based on the 

Neuron Folder setting in the Setup dialog box. 
single mode: Open an improved skeleton image. 
also uses: cell body points (.txt),corresponding Cell Body ROIs (if present), neuron (if saving 

overlay). 
 
Output 
Skeleton data ( 
Polygon data (area and perimeter) and images of the polygons 
• folder myExper_finalSkels containing files image#fs.tif,  
• folder myExper_dat containing myExper_skelData.txt and, if polygon was run,   

myExper_allData.txt which combines the data from Polygon and Measure Skeleton into 
one .txt file. 

• folder myExper_ overlaysAll containing files image#_overlayAll.tif (recommended) 
 
How To Use 
  Run by going to Plugins > NeuronMetrics > Polygon. 

• Fully automatic.  
• Various stages of image processing will be displayed briefly. 
• The data and images are automatically saved. 
• Check overlay of all features computed. 
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Polygon Plugin 

Purpose 
Computes the convex hull polygon which represents the territory occupied by the 
skeletonized neuron and the cell body ROI. Also computes the area and perimeter of the 
polygon. 
 
Input 
batch mode: The final skeleton image folder is automatically found based on the Neuron 

Folder setting in the Setup dialog box. 
single mode: Open a final skeleton image. 
also uses: corresponding Cell Body ROIs (if present), neuron (if saving overlay). 
 
Output 
Polygon data (area and perimeter) and images of the polygons 
• folder myExper_polys containing files image#p.tif 
• folder myExper_dat containing file myExper_polyData.txt 
 
How To Use 
  Run by going to Plugins > NeuronMetrics > Polygon. 

• Fully automatic.  
• Various stages of image processing will be displayed briefly. 
• The data and polygon images are automatically saved. 
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Explanations 

 
Uniform Versus Non-uniform Neuron Signal 

 
Skeletonization may be done in one of two modes depending on whether the signal in the 
neuron is uniform throughout or is non-uniform. Examples are show below. 
 

 
Example of uniform signal. (A) Neuron with high, uniform signal throughout. (B) 
Enlargement of a broad region with uniform signal (see arrow in A). Adapted from Fig. 1 of 
Narro et al. (2007). 
 

 
Example of non-uniform signal. (A) Neuron with non-uniform signal. (B) Skeleton, created 
by processing in non-uniform mode, overlaid on neuron. (C) Enlargement of broad region 
with non-uniform signal. (D) Skeleton created by processing in non-uniform mode. (E) 
Skeleton created by erroneously skeletonizing in uniform mode is a poor representation of 
the region. Adapted from Fig. 5 of Narro et al. (2007). 
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Faces 

 
Faces are the regions of the image that are enclosed when neurites contact one another. 
For an explanation of how they are used to correct the branch count, see Narro et al. 
(2007). 
 

 
Examples of neurons with numerous inter-neurite contacts and the corresponding 
skeletonized images in which each face region is differentially colored.  Reproduced from 
Fig. 6 of Narro et al., 2007. 
 
 

Polarity Index 
 
The polarity index is defined as the percentage of total length contributed by the primary 
neurite with the greatest combined length of its trunk and arbor (Kraft et al., 1998). 
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Tips 

 
 

How to View a Set of Images 
 
There are software tools that enable you to view a set of images. Such tools have forward 
and backward arrows to facilitate rapid viewing of all images in the folder. 
 
On a Windows computer use: 
• Microsoft Office Picture Manager 
• Windows Picture and Fax Viewer 
 
 

Update .txt files 
 
• If you re-run a plugin that generates a text file, the .txt files are auto-incremented by 

appending $1, $2, etc. to the end of the file name so data are not lost. However, plugins 
use the text file with a name that does NOT have $# appended to it (i.e., the first file 
created). Thus, if you re-run a plugin that generates a .txt file, you must edit the FIRST 
file created to add updated data to it, or you must rename the correct text file by deleting 
the $# from its name. If you do not, downstream plugins that depend on the data in the 
.txt file will skip or fail on the images for which data cannot be found. 

 
• NEVER open a .txt file in Microsoft Word. Word inserts all sorts of hidden things in files 

and you may have trouble getting rid of them. Such hidden delights may cause problems 
when a NeuronMetrics plugin tries to read the .txt file. 

 
• Use a text editor such as WordPad to open, edit, and save a .txt file. 
 
 

Do Not Multi-task 
 
To avoid problems, do not use any other applications while running NeuronMetrics. Do not 
move the mouse around except to provide user input that NeuronMetrics needs. This means 
do not read e-mail, read electronic journal articles, or work on some document. 
NeuronMetrics seems to get confused about which window is active. 
 
 

About .roi Files 
 
The file extension .roi is used for files that store information about a region of interest 
(ROI), also referred to as a “selection”. In ImageJ, if such a file is opened directly, the ROI 
will be visible. Its shape will be informative, but not its location. If instead an image file is 
open first, say the image on which the ROI was created, and then the .roi file is opened, the 
ROI will display in the location on which it was created. A .roi file can be opened on any 
image having the same dimensions as the image on which the ROI was created. In other 
words, a ROI that was created on a neuron image and saved, can be opened on the 
corresponding skeleton file.
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